炒股侠 - 打造最好的股票学习网站!

股票入门基础知识,炒股侠股票学习网

当前位置: 主页 > 技术指标 > WR > 钻石威廉指标改进副图、源码、贴图

钻石威廉指标改进副图、源码、贴图

  钻石威廉指标改进副图、源码、贴图
  
  钻石威廉指标由三条不同时间周期的威廉指标线构成:
  
WR13:100*(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13));
WR34:100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34));
WR89:100*(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89));
  
  其中每条传统的威廉指标线都是显示上底(极值为100)下顶(极值为0),和许多技术指标显示的上顶下底不一样,直接影响了大家的使用习惯,有必要将其改造为上顶下底模式。有的软件是在传统的威廉指标后面-100,变成了上顶(极值为0)下底(极值为-100)模式。研究后,我采用了100-传统威廉指标,形成上顶(极值为100)下底(极值为0)模式:100-(HHV(H,N)-C)/(HHV(H,N)-LLV(L,N))*100,换算后为(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100。这正是KDJ指标第一句RSV的写法,难怪说KDJ指标是在威廉指标基础上发展起来的哈。
  
  钻石威廉指标是比较三条短、中、长不同周期的威廉指标关系来研判股价运行趋势的指标,其中一条线、两条线、三条线冲顶撞底的作用是特有的,炒股侠进行了分别设置,形成了WRR指标。
  
  改进后的钻石威廉指标源码如下:
  
WR1:(C-LLV(L,N1))/(HHV(H,N1)-LLV(L,N1))*100,COLORWHITE;
WR2:(C-LLV(L,N2))/(HHV(H,N2)-LLV(L,N2))*100,COLORYELLOW;
WR3:(C-LLV(L,N3))/(HHV(H,N3)-LLV(L,N3))*100,COLORMAGENTA;
WRH:=MAX(MAX(WR1,WR2),WR3);
WRL:=MIN(MIN(WR1,WR2),WR3);
WRDL:=MIN(MAX(ABS(WR1-WR2),ABS(WR1-WR3)),ABS(WR2-WR3));
STICKLINE(WR1>94,100,101,2,0),COLORWHITE;
STICKLINE(WRH>95 && WRDL<2 && WR2>80,100,101,2,0),COLORYELLOW;
STICKLINE(WRH>95 && WRL>90 && WRDL<2 && WR2>90,100,101,2,0),COLORMAGENTA;
STICKLINE(WR1<5,-1,0,2,0),COLORWHITE;
STICKLINE(WRL<5 && WRDL<0.5,-1,0,2,0),COLORYELLOW;
STICKLINE(WRL<5 && WRH<10 && WRDL<0.5,-1,0,2,0),COLORMAGENTA;
  
  N1默认13,N2默认34,N3默认89.

钻石威廉指标改进副图、源码、贴图
------分隔线----------------------------
WR内容分类
相关内容